#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:([-\/?&])\1|[^A-Za-z0-9\/&=?-])"
Local $sString = "item/643fe4ac-e87d-4b71-8fd1-522154f933c2/okay" & @CRLF & _
"person/adam?height=23&favcolor=blue" & @CRLF & _
"city/building/916fe4ac-e87d-4b71-8fd1-522154f933r5" & @CRLF & _
"item/643fe4ac--e87d-4b71-8fd1---522154f933c2/okay" & @CRLF & _
"person/adam??height=23&favcolor=blue" & @CRLF & _
"city/@/916fe4ac-e87d-4b71-8fd1-522154f933r5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")