import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:([-\\/?&])\\1|[^A-Za-z0-9\\/&=?-])";
final String string = "item/643fe4ac-e87d-4b71-8fd1-522154f933c2/okay\n"
+ "person/adam?height=23&favcolor=blue\n"
+ "city/building/916fe4ac-e87d-4b71-8fd1-522154f933r5\n"
+ "item/643fe4ac--e87d-4b71-8fd1---522154f933c2/okay\n"
+ "person/adam??height=23&favcolor=blue\n"
+ "city/@/916fe4ac-e87d-4b71-8fd1-522154f933r5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}