using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""'])\s*(SELECT)(?:\s+.*)?\s+(FROM)(?:\s+.*)?\1(?:[^\w]|$)";
string input = @" SELECT * FROM tbl -- no match - not in a string
""SELECT * FROM tbl"" -- matches - in a double-quoted string
'SELECT * FROM tbl;' -- matches - in a single-quoted string
'SELECT * FROM it's -- no match - letter after end quote
""SELECT * FROM tbl' -- no match - quotation marks don't match
'SELECT * FROM tbl"" -- no match - quotation marks don't match
""select * from tbl"" -- no match - keywords not upper case
'Select * From tbl' -- no match - still not all upper case
""SELECT col1 FROM"" -- matches - even though no table name
' SELECT col1 FROM ' -- matches - as above with more whitespace
'SELECT col1, col2 FROM' -- matches - with multiple columns";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}