use strict;
my $str = ' SELECT * FROM tbl -- no match - not in a string
"SELECT * FROM tbl" -- matches - in a double-quoted string
\'SELECT * FROM tbl;\' -- matches - in a single-quoted string
\'SELECT * FROM it\'s -- no match - letter after end quote
"SELECT * FROM tbl\' -- no match - quotation marks don\'t match
\'SELECT * FROM tbl" -- no match - quotation marks don\'t match
"select * from tbl" -- no match - keywords not upper case
\'Select * From tbl\' -- no match - still not all upper case
"SELECT col1 FROM" -- matches - even though no table name
\' SELECT col1 FROM \' -- matches - as above with more whitespace
\'SELECT col1, col2 FROM\' -- matches - with multiple columns';
my $regex = qr/(["'])\s*(SELECT)(?:\s+.*)?\s+(FROM)(?:\s+.*)?\1(?:[^\w]|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}