re = /(\w+)="(\d+)"/
str = '<log pos_start="40652288" end_position="40689664" log_type="1" length="37376" block_id="4024" block_position="18"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end