// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\w+)="(\d+)""#).unwrap();
let string = "<log pos_start=\"40652288\" end_position=\"40689664\" log_type=\"1\" length=\"37376\" block_id=\"4024\" block_position=\"18\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}