#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\r?\n|\r){2,}"
Local $sString = "#Example-1#" & @CRLF & _
"The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd." & @CRLF & _
"" & @CRLF & _
"jfbgfdgdf sgdsgsd." & @CRLF & _
"#End Example-1#" & @CRLF & _
"" & @CRLF & _
"#Example-2#" & @CRLF & _
"The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd." & @CRLF & _
"jfbgfdgdf sgdsgsd." & @CRLF & _
"#End Example-2#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")