import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\r?\\n|\\r){2,}";
final String string = "#Example-1#\n"
+ "The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.\n\n"
+ "jfbgfdgdf sgdsgsd.\n"
+ "#End Example-1#\n\n"
+ "#Example-2#\n"
+ "The correct answer is (B) 2 to 3. jfbgfdgdf sgdsgsd.\n"
+ "jfbgfdgdf sgdsgsd.\n"
+ "#End Example-2#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}