$re = '/\b(?:a(?:ndroid|vantgo)|b(?:lackberry|olt|o?ost)|cricket|docomo|hiptop|i(?:emobile|p[ao]d)|kitkat|m(?:ini|obi)|palm|(?:i|smart|windows )phone|symbian|up\.(?:browser|link)|tablet(?: browser| pc)|(?:hp-|rim |sony )tablet|w(?:ebos|indows ce|os))/i';
$str = 'android avantgo blackberry bolt boost cricket docomo hiptop iemobile ipad ipod iphone kitkat mini mobi palm smartphone windows phone symbian up.browser up.link tablet pc tablet browser hp-tablet sony tablet rim tablet webos windows ce wos';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);