#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\.directive\(['"]([^'"\n]+)['"]"
Local $sString = ""'use strict';" & @CRLF & _
"" & @CRLF & _
"angular.module('testplugin', [])" & @CRLF & _
".config(function () {})" & @CRLF & _
".run(function() {})" & @CRLF & _
".controller('TestPlugin', function ($scope) {" & @CRLF & _
"})" & @CRLF & _
".directive('myTestPlugin', function () {" & @CRLF & _
" return {" & @CRLF & _
" restrict: 'E'," & @CRLF & _
" template: 'test test test test test test...'" & @CRLF & _
" };" & @CRLF & _
"})" & @CRLF & _
"" & @CRLF & _
".directive('myTestPlugin2222', function () {" & @CRLF & _
" return {" & @CRLF & _
" restrict: 'E'," & @CRLF & _
" template: 'test test test test test test...'" & @CRLF & _
" };" & @CRLF & _
"})" & @CRLF & _
"" & @CRLF & _
".directive('myTestPlugin3333', function () {" & @CRLF & _
" return {" & @CRLF & _
" restrict: 'E'," & @CRLF & _
" template: 'test test test test test test...'" & @CRLF & _
" };" & @CRLF & _
"})" & @CRLF & _
"" & @CRLF & _
".directive('myTestPlugin4444444', function () {" & @CRLF & _
" return {" & @CRLF & _
" restrict: 'E'," & @CRLF & _
" template: 'test test test test test test...'" & @CRLF & _
" };" & @CRLF & _
"})"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")