import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.directive\\(['\"]([^'\"\\n]+)['\"]";
final String string = "\"'use strict';\n\n"
+ "angular.module('testplugin', [])\n"
+ ".config(function () {})\n"
+ ".run(function() {})\n"
+ ".controller('TestPlugin', function ($scope) {\n"
+ "})\n"
+ ".directive('myTestPlugin', function () {\n"
+ " return {\n"
+ " restrict: 'E',\n"
+ " template: 'test test test test test test...'\n"
+ " };\n"
+ "})\n\n"
+ ".directive('myTestPlugin2222', function () {\n"
+ " return {\n"
+ " restrict: 'E',\n"
+ " template: 'test test test test test test...'\n"
+ " };\n"
+ "})\n\n"
+ ".directive('myTestPlugin3333', function () {\n"
+ " return {\n"
+ " restrict: 'E',\n"
+ " template: 'test test test test test test...'\n"
+ " };\n"
+ "})\n\n"
+ ".directive('myTestPlugin4444444', function () {\n"
+ " return {\n"
+ " restrict: 'E',\n"
+ " template: 'test test test test test test...'\n"
+ " };\n"
+ "})\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}