# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\(\s*([a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*(ni|in|\*|\/|\+|\-|==|!=|>|>=|<|<=)\s*([a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*\))"
test_str = ("(a in b)\n\n"
"(a ni b)\n\n"
"(a in [1,2,3])\n\n"
"([1,2,3] == [1,2,3])\n\n"
"(a == 'Ahmad Hajjar')\n\n"
"((a+1)==b)\n\n"
"(1==1)\n\n"
"( a == a)\n"
"(1==2)\n\n"
"(x1!=y)\n\n"
"(xa1*3)\n\n"
"((7*3)==21)\n\n"
"((17*9)!=(a+b))\n\n"
"((( a + b )*(c-d))==(5/2))\n\n"
"( a+b)\n\n"
"( a - b)\n\n"
"( a/b )\n\n"
"( a * b )\n\n"
"(ahmad>feras)\n\n"
"(ahmad>=feras)\n\n"
"(feras<ahmad)\n\n"
"(feras<=ahmad)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.