package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\((.*)\)$`)
var str = `Табуретка (1) (2) (меня)
Голова моя
Голова (моя)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}