$re = '/.*\((.*)\)$/um';
$str = 'Табуретка (1) (2) (меня)
Голова моя
Голова (моя)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);