$re = '/(?|(<tr>)|<td>(.*)<\/td>)/isU';
$str = '<tr><td>r1c1</td> <td>r1c2</td><td>r1c3</td></tr> <tr><td>r2c1</td> <td>r2c2</td></tr> <tr><td>r3c1</td> <td>r3c2</td></tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);