re = /(?|(<tr>)|<td>(.*)<\/td>)/i
str = '<tr><td>r1c1</td> <td>r1c2</td><td>r1c3</td></tr> <tr><td>r2c1</td> <td>r2c2</td></tr> <tr><td>r3c1</td> <td>r3c2</td></tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end