using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# SETTINGS
(?<ANCHORED>){1}
(?<NO_SIGN_DUP>){1}
(?<PYTHON_POW>){1}
(?<COMMENTS>){0}
(?(ANCHORED)^(?&s)*)
(?(DEFINE)
(?<s>(?(COMMENTS)(?:\s+|\/\*[\s\S]*?\*\/|\/\/.*|\#.*)|\s+))
(?<sign>(?(NO_SIGN_DUP)(?<=(?<_>[\s\S]))(?!(?P=_)))[-+])
(?<base>\d+(?:\.\d*)?|\d*\.\d+)
(?<exp>(?:[eE][+-]?\d+))
(?<num>(?&sign)?(?&base)(?&exp)?(?!\w))
(?<bracketed>\((?&s)*(?&expr)(?&s)*\))
(?<atom>(?&num)|(?&bracketed))
(?<pow>(?&atom)(?:(?&s)*(?(PYTHON_POW)(?:\^|\*\*)|\^)(?&s)*(?&pow))*)
(?<mul>(?&pow)(?:(?&s)*[*\/](?&s)*(?&mul))*)
(?<add>(?&mul)(?:(?&s)*[+-](?&s)*(?&add))*)
(?<expr>(?&add))
)
(?&expr)
(?(ANCHORED)(?&s)*$)";
string input = @"0
::
1
::
+1
::
-1
::
1.e-1
::
1e1
::
.1e+1
::
-6*((2**(2+4))/3)
::
0*0
::
0+0
::
0/0
::
0^0
::
0**0
::
0-0
::
5 - -2
::
5- -2
::
5+-2
::
.1
::
1.
::
1.1
::
-2
::
5 * (2 + 5 /* comment */ // )
- 1)
INVALID: // Separated by :: to prevent parsing multiple examples
.
::
1e
::
1e+
::
1e-
::
e2
::
+
::
-
::
5 --2
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}