const regex = /# SETTINGS
(?<ANCHORED>){1}
(?<NO_SIGN_DUP>){1}
(?<PYTHON_POW>){1}
(?<COMMENTS>){0}
(?(ANCHORED)^(?&s)*)
(?(DEFINE)
(?<s>(?(COMMENTS)(?:\s+|\/\*[\s\S]*?\*\/|\/\/.*|\#.*)|\s+))
(?<sign>(?(NO_SIGN_DUP)(?<=(?<_>[\s\S]))(?!(?P=_)))[-+])
(?<base>\d+(?:\.\d*)?|\d*\.\d+)
(?<exp>(?:[eE][+-]?\d+))
(?<num>(?&sign)?(?&base)(?&exp)?(?!\w))
(?<bracketed>\((?&s)*(?&expr)(?&s)*\))
(?<atom>(?&num)|(?&bracketed))
(?<pow>(?&atom)(?:(?&s)*(?(PYTHON_POW)(?:\^|\*\*)|\^)(?&s)*(?&pow))*)
(?<mul>(?&pow)(?:(?&s)*[*\/](?&s)*(?&mul))*)
(?<add>(?&mul)(?:(?&s)*[+-](?&s)*(?&add))*)
(?<expr>(?&add))
)
(?&expr)
(?(ANCHORED)(?&s)*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# SETTINGS
(?<ANCHORED>){1}
(?<NO_SIGN_DUP>){1}
(?<PYTHON_POW>){1}
(?<COMMENTS>){0}
(?(ANCHORED)^(?&s)*)
(?(DEFINE)
(?<s>(?(COMMENTS)(?:\\s+|\\\/\\*[\\s\\S]*?\\*\\\/|\\\/\\\/.*|\\#.*)|\\s+))
(?<sign>(?(NO_SIGN_DUP)(?<=(?<_>[\\s\\S]))(?!(?P=_)))[-+])
(?<base>\\d+(?:\\.\\d*)?|\\d*\\.\\d+)
(?<exp>(?:[eE][+-]?\\d+))
(?<num>(?&sign)?(?&base)(?&exp)?(?!\\w))
(?<bracketed>\\((?&s)*(?&expr)(?&s)*\\))
(?<atom>(?&num)|(?&bracketed))
(?<pow>(?&atom)(?:(?&s)*(?(PYTHON_POW)(?:\\^|\\*\\*)|\\^)(?&s)*(?&pow))*)
(?<mul>(?&pow)(?:(?&s)*[*\\\/](?&s)*(?&mul))*)
(?<add>(?&mul)(?:(?&s)*[+-](?&s)*(?&add))*)
(?<expr>(?&add))
)
(?&expr)
(?(ANCHORED)(?&s)*$)', 'gm')
const str = `0
::
1
::
+1
::
-1
::
1.e-1
::
1e1
::
.1e+1
::
-6*((2**(2+4))/3)
::
0*0
::
0+0
::
0/0
::
0^0
::
0**0
::
0-0
::
5 - -2
::
5- -2
::
5+-2
::
.1
::
1.
::
1.1
::
-2
::
5 * (2 + 5 /* comment */ // )
- 1)
INVALID: // Separated by :: to prevent parsing multiple examples
.
::
1e
::
1e+
::
1e-
::
e2
::
+
::
-
::
5 --2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}