$re = '/(\w+)\s*=\s*(?:")?(.*?(?="?\s+\w+\s*=|(?:"?)$))/';
$str = 'a ="First Field" b=SecondField c3= "Third field value" delta = "" e_value = five!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);