re = /(\w+)\s*=\s*(?:")?(.*?(?="?\s+\w+\s*=|(?:"?)$))/
str = 'a ="First Field" b=SecondField c3= "Third field value" delta = "" e_value = five!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end