const regex = /ip(?:hone|[ao]d) os[ _]\K[\d_]+/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ip(?:hone|[ao]d) os[ _]\\K[\\d_]+', 'i')
const str = `Mozilla/5.0 (iPhone; CPU iPhone OS 11_2_1 like Mac OS X) AppleWebKit/604.4.7 (KHTML, like Gecko) Version/11.0 Mobile/15C153 Safari/604.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}