re = /ip(?:hone|[ao]d) os[ _]\K[\d_]+/i
str = 'Mozilla/5.0 (iPhone; CPU iPhone OS 11_2_1 like Mac OS X) AppleWebKit/604.4.7 (KHTML, like Gecko) Version/11.0 Mobile/15C153 Safari/604.1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end