import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?://www\\.domain\\.com/[^/-]*/$";
final String string = "http://www.domain.com/goodday/\n"
+ "http://www.domain.com/today-is-gooddady/\n"
+ "http://www.domain.com/life-is-good/enjoy-a-happy-life/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}