re = /^https?:\/\/www\.domain\.com\/[^\/-]*\/$/m
str = 'http://www.domain.com/goodday/
http://www.domain.com/today-is-gooddady/
http://www.domain.com/life-is-good/enjoy-a-happy-life/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end