re = /G\(([^,]+)(, ?([^),]+))*\)/m
str = 'not me G(select me, and me)
G(select me) G(also me)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end