package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)^(\d+)\R
[->\d: ,]+\R
((?:.+\R?)+)`)
var str = `3
00:01:40,200 --> 00:01:43,326
english part
4
00:01:43,534 --> 00:01:44,851
خط فارسی
5
00:01:45,063 --> 00:01:48,485
complex part مخلوط
6
00:01:45,063 --> 00:01:48,485
complex part مخلوط
in 2 lines`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}