$re = '~^(\d+)\R
[->\d: ,]+\R
((?:.+\R?)+)~mx';
$str = '3
00:01:40,200 --> 00:01:43,326
english part
4
00:01:43,534 --> 00:01:44,851
خط فارسی
5
00:01:45,063 --> 00:01:48,485
complex part مخلوط
6
00:01:45,063 --> 00:01:48,485
complex part مخلوط
in 2 lines';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);