re = /\n?\d*?\n?^.* --> [012345]{2}:.*$/m
str = '1
00:00:04,019 --> 00:00:07,299
line1
line2
2
00:00:07,414 --> 00:00:09,155
line1
00:00:09,276 --> 00:00:11,429
line1
00:00:11,549 --> 00:00:14,874
line1
line2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end