import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[*]\\s(?!\\d|--).+(?:\\n(?!--).*)*";
final String string = "* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
+ "NonConformity 0001 :\n"
+ "Type of nonconformity : Scratch\n"
+ "* NonConformity 0002 :\n"
+ "Type of nonconformity : Scratch - cosmetical item\n"
+ "* Il a été constaté des rayures sur L'ENS CASQUETTE réf :\n"
+ "D54.\n"
+ "* Voir standard doc.\n"
+ "* Nous demandons le renvoi de la pièce pour une remise en\n"
+ "conformité.\n"
+ "-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
+ "-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
+ "02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
+ "Task Completed : 0100 `` DEC0 ``\n"
+ "Decision Taken : REJECT\n"
+ "Justification :\n\n"
+ "* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
+ "NonConformity 0001 :\n"
+ "Type of nonconformity : Scratch\n"
+ "* 4 NonConformity 0002 :\n"
+ "Type of nonconformity : Scratch - cosmetical item\n"
+ "* Il a été constaté des rayures sur L'ENS CASQUETTE réf :\n"
+ "D54.\n"
+ "* Voir standard doc.\n"
+ "* Nous demandons le renvoi de la pièce pour une remise en\n"
+ "conformité.\n"
+ "-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
+ "-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --\n"
+ "02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~\n"
+ "Task Completed : 0100 `` DEC0 ``\n"
+ "Decision Taken : REJECT\n"
+ "Justification :";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}