import Foundation
let pattern = #"^[*]\s(?!\d|--).+(?:\n(?!--).*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
NonConformity 0001 :
Type of nonconformity : Scratch
* NonConformity 0002 :
Type of nonconformity : Scratch - cosmetical item
* Il a été constaté des rayures sur L'ENS CASQUETTE réf :
D54.
* Voir standard doc.
* Nous demandons le renvoi de la pièce pour une remise en
conformité.
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
Task Completed : 0100 `` DEC0 ``
Decision Taken : REJECT
Justification :
* 02.04.2021 09:23:25 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
NonConformity 0001 :
Type of nonconformity : Scratch
* 4 NonConformity 0002 :
Type of nonconformity : Scratch - cosmetical item
* Il a été constaté des rayures sur L'ENS CASQUETTE réf :
D54.
* Voir standard doc.
* Nous demandons le renvoi de la pièce pour une remise en
conformité.
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
02.04.2021 09:31:27 CET #PRS~ #PRS~ ( #UID~ ) Tél. #TEL~ #TEL~
Task Completed : 0100 `` DEC0 ``
Decision Taken : REJECT
Justification :
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)