using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"String(*SKIP)(*FAIL)|ring";
string input = @"The bells are ringing is a String
This is an string that is not ringing";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}