package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)String(*SKIP)(*FAIL)|ring`)
var str = `The bells are ringing is a String
This is an string that is not ringing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}