$re = '/String|(\w*ring\w*)/i';
$str = 'The bells are ringing is a String
This is an string that is not ringing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);