re = /String|(\w*ring\w*)/i
str = 'The bells are ringing is a String
This is an string that is not ringing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end