$re = '/([[ ;(){},\'"]?)(\b_[a-zA-Z_0-9-]*\b)([] =;\/*+"\'{},-]?)/';
$str = '_var
test_var';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);