re = /([[ ;(){},'"]?)(\b_[a-zA-Z_0-9-]*\b)([] =;\/*+"'{},-]?)/
str = '_var
test_var'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end