using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(foo: ).*";
string substitution = @"$1baz";
string input = @"foo: bar";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}