using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(pinkglass|greenapple)\s(redbook|bluepen|yellowglass)\s(pinkglass|greenapple)$";
string input = @"pinkglass redbook greenapple
greenapple bluepen pinkglass";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}