// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(pinkglass|greenapple)\s(redbook|bluepen|yellowglass)\s(pinkglass|greenapple)$").unwrap();
let string = "pinkglass redbook greenapple
greenapple bluepen pinkglass";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}