import re
regex = re.compile(r'<iframe .*?\bsrc="(https?://fast\.player\.liquidplatform\.com/pApiv2/embed/e50a2b66dc19adc532f288eb4bf2d302/[^"]+)', flags=re.MULTILINE)
test_str = ("<iframe src=\"https://fast.player.liquidplatform.com/pApiv2/embed/e50a2b66dc19adc532f288eb4bf2d302/f2c5f6ca3a4610c55d70cb211ef9d977\" webkitallowfullscreen=\"\" width=\"490\">\n"
"<iframe allowfullscreen=\"\" frameborder=\"0\" height=\"276\" mozallowfullscreen=\"\" scrolling=\"no\" src=\"https://fast.player.liquidplatform.com/pApiv2/embed/e50a2b66dc19adc532f288eb4bf2d302/%20f2c5f6ca3a4610c55d70cb211ef9d977\" webkitallowfullscreen=\"\" width=\"490\"></iframe>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")