re = /<iframe .*?\bsrc="(https?:\/\/fast\.player\.liquidplatform\.com\/pApiv2\/embed\/e50a2b66dc19adc532f288eb4bf2d302\/[^"]+)/m
str = '<iframe src="https://fast.player.liquidplatform.com/pApiv2/embed/e50a2b66dc19adc532f288eb4bf2d302/f2c5f6ca3a4610c55d70cb211ef9d977" webkitallowfullscreen="" width="490">
<iframe allowfullscreen="" frameborder="0" height="276" mozallowfullscreen="" scrolling="no" src="https://fast.player.liquidplatform.com/pApiv2/embed/e50a2b66dc19adc532f288eb4bf2d302/%20f2c5f6ca3a4610c55d70cb211ef9d977" webkitallowfullscreen="" width="490"></iframe>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end