import re
regex = re.compile(r"googledrive\.com.+_thumb", flags=re.IGNORECASE)
test_str = "https://googledrive.com/host/0B_8okaqRyPERVlM0OVVCS29TVzQ/1018-7378-21283_thumb.jpg"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")