re = /googledrive\.com.+_thumb/i
str = 'https://googledrive.com/host/0B_8okaqRyPERVlM0OVVCS29TVzQ/1018-7378-21283_thumb.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end