package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((\+\d{2}|0)9\d{9})$`)
var str = `+989122045941`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}