$re = '/^((\+\d{2}|0)9\d{9})$/';
$str = '+989122045941';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);