package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:{[^{}]*}|"[^"]*"|\([^()]*\)|\[[^][]*\])|\S+`)
var str = `another parse option {(["gets confusing"])}
a b c d e f "something else here"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}