$re = '/(?:{[^{}]*}|"[^"]*"|\([^()]*\)|\[[^][]*\])|\S+/';
$str = 'another parse option {(["gets confusing"])}
a b c d e f "something else here"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);