$re = '/\b(0|[1-9]\d*)\b/m';
$str = '0, 50, 798
01, 046, 0014, 00, 0001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);