import re
regex = re.compile(r"\b(0|[1-9]\d*)\b", flags=re.MULTILINE)
test_str = ("0, 50, 798\n"
"01, 046, 0014, 00, 0001")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")