$re = '/\d+(?:\.\d+)?/';
$str = 'ghjkhjgbkhj123.45khgbkhjgk67 8kjhgkj hg13.99sads';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);